НЕ рекламируется сайт в серфинге

SEM69

Участник
#1
Мне установили серфинг на проект. После чего перестала работать капча при регистрации.
Я сделал редирект через htaccess
с http на https. и капча заработала . Но теперь не рекламируются сайты протокола http
Стоит просто пустая стр. нет перехода на рекл . сайт. Время тикает , капча подтверждается, серебро на счет списывается , а сайта не видно
 

geronimo

Команда форума
Гл. Модератор
#3
так серфин не работает с ssl ,только на поддомен переносить
 

jameson

Команда форума
Гл. Модератор
#4
так серфин не работает с ssl ,только на поддомен переносить
А в чем там проблема? Я просто я не разу серфинг не ставил, может его можно переделать под https?
Автор скинь файлы плагина, я гляну, может быть поправлю.
 

geronimo

Команда форума
Гл. Модератор
#5
А в чем там проблема? Я просто я не разу серфинг не ставил, может его можно переделать под https?
Автор скинь файлы плагина, я гляну, может быть поправлю.
На самом деле я не в курсе в чем проблема,но плагин у нас в ресурсах есть
 

jameson

Команда форума
Гл. Модератор
#6
СТОП! Из головы вылетело, я делал букс с серфингом задания.онлайн на движке фф, но не помню почему он так и остался без дела, то клиент отказался, толи еще что, не суть! Но там все работает. Пруф во вложении.
 

Вложения

  • 694,9 KB Просмотры: 105

jameson

Команда форума
Гл. Модератор
#8
Да я понимаю, плагин я видел в загрузках, но я же не знаю что именно установили автору, да и вообще обычно получается, что с каждым конкретным сайтом проблемы решать нужно именно с файлами этого сайта, у кого-то руки зачесались, он добавил пару строк кода в файл и все заверьте, стандартное решение уже не годно. Но плагин этот гляну позже, поставлю и переделаю под ssl, просто я не помню как я тогда сделал чтобы это работало :) Видимо по ситуации ориентировался.
 

jameson

Команда форума
Гл. Модератор
#10
Ну говорю же дайте файлы вашего плагина, когда буду смотреть что не так с основным плагином, заодно и ваш проверю.
 

jameson

Команда форума
Гл. Модератор
#11
Кажется (могу ошибаться) проблема была решена следующим образом - вместо .htaccess редиректа на SSL, я поставил редирект через index.php
PHP:
if(empty($_SERVER['HTTPS']) || $_SERVER['HTTPS'] == "off"){
    $redirect = 'https://' . $_SERVER['HTTP_HOST'] . $_SERVER['REQUEST_URI'];
    header('HTTP/1.1 301 Moved Permanently');
    header('Location: ' . $redirect);
    exit();
}
Попробуйте и отпишитесь, просто сейчас глянул быстро файлы вышеуказанного сайта и подумал что видимо не просто так редирект на ssl стоит не как обычно, а через php :)
 

viktor70

Заблокирован
#12
Есть способ один, как обойти https в серфинге. Сделаю хотя бы скрины, чтобы понятно для всех было и тему открою, но думаю, что завтра уже.
 

jameson

Команда форума
Гл. Модератор
#14
На самом деле я был не прав, действительно iframe не даст спокойно показывать сайты без ssl, создаете в корне файл get.php с кодом:

PHP:
<?php
if (isset($_GET['url'])) {
    $url = $_GET['url'];
    $ch = curl_init();
    $timeout = 5;
    curl_setopt($ch, CURLOPT_URL, $url);
    curl_setopt($ch, CURLOPT_RETURNTRANSFER, 1);
    curl_setopt($ch, CURLOPT_CONNECTTIMEOUT, $timeout);
    $data = curl_exec($ch);
    curl_close($ch);
    echo $data;
} ?>
И меняете ссылку фрейма с

PHP:
    <frame name="frame_site" src="<?php echo $result['url']; ?>" marginwidth="0" marginheight="0" frameborder="0" />
на
PHP:
    <frame name="frame_site" src="https://ВАШ_САЙТ/get.php?url=<?php echo $result['url']; ?>" marginwidth="0" marginheight="0" frameborder="0" />
в файле _serfing_view.php

криво, зато работает :)
 

jameson

Команда форума
Гл. Модератор
#17
Вышлите ссылку на сайт в ЛС, я гляну и скажите на какое объявление нажать, просто на тестовом проекте все работало.
 

viktor70

Заблокирован
#20
Всё понял! надо вставить вместо:
Код:
<frame name="frame_site" src="<?php echo $result['url']; ?>" marginwidth="0" marginheight="0" frameborder="0" />
это:
Код:
 <frame name="frame_site" src="https://proxyserfing.psweb.by/browse.php?u=<?php echo $result['url']; ?>" marginwidth="0" marginheight="0" frameborder="0" />
И всё работает!!!
 
Сверху